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Introduction
Welcome to Fahrenheit! Fahrenheit is an accounting software built for the needs of small and medium-
sized businesses, with a special focus on efficiency and usability. As a small, family-owned business, 
we’re striving to meet the needs of a market that has been forgotten by many of the larger players in  
this space. As an example, we’re providing a software that is not cloud-based or subscription-based: 
you retain the ownership of your own data and you decide what to do with it and who you would like to 
have access.

In this guide, we’d like to introduce you to the world of Fahrenheit, and how to maximize your return on 
investment. We welcome feedback—please let us know if there’s functionality that we could add to the 
software to enhance your experience or speed up your workflow (and also feel free to let us know how 
this document could be improved). Thanks for your interest and participation!

Best wishes,

Jonathan Tiffany
CEO
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Setting Up Fahrenheit
Before you can begin to work with your books, you must create a new books file. If you’re keeping 
track of records for more than one entity, you can create multiple sets of books.

When you first open up Fahrenheit, you will need to create a new file. Go to File > Switch Books if this 
screen is not already visible:

Click New File to start a locally stored set of books; you will then be prompted for a location to save 
your books. Note that the books are saved as a folder, not as a file. This means that when you go to 
back up your books, you will need to copy the entire folder, not just a single file. It also means that 
when you go to open different books, you’ll need to select the folder, not one of the files in it, there as 
well. The files in the folder should not be modified or they may irreparably damage your records. To 
back up, copy the entire folder to your backup location.

Setting Up Your Company
Upon saving your books file, Fahrenheit will automatically open it. The next step is to enter your com-
pany’s information, as it will show up on invoices, estimates, sales orders, reports, etc. Click the Miscella-
neous button on the Navigation screen or the left sidebar:
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Then click Company Information, and fill in the necessary fields.
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Navigation Tips
The Home or Navigation screen is the primary way to go places in Fahrenheit:

 

Note that the buttons down the left (the “sidebar”) are the same icons as the buttons in the center of  
the screen. That way, you can become familiar with the meaning of the icons by using the labeled but-
tons in the center of the screen, and switch to the unlabeled but faster buttons on the sidebar as you 
become more comfortable with Fahrenheit (also, if you hover your mouse over a sidebar button, it will 
show a tooltip with its label).

The big squares with account balances in them can be clicked to see the transactions that make up 
those balances. If you’d like to change the accounts that show here, go to the Menu (three lines in the 
upper left of the window) > File > Preferences > Functionality and click the Edit Dashboard button.

The Menu (three lines in the upper left of the window) is where you go for things like switching books,  
editing reports, or setting user preferences:
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Here the File menu is open. You can click Switch Books to change to a different Fahrenheit file. Connect 
to Server is used if you have a Networked Edition of Fahrenheit. Preferences allows you to set various 
useful settings to make Fahrenheit run more like you would like it. Manage Users is useful mainly in a 
networked environment, but you can also use it to set a password to open your file.

The Go menu has the same functionality as the Home screen; the New menu allows you to create new 
records in various tables throughout the program. The Reports lists available system-wide reports; 
these are also available on the Home screen. The History menu allows you to see previous records that 
were open, and navigate back to them. And the Help menu allows you to view this manual, open the 
Remote Support system, or view the About screen.

Keyboard Shortcuts for Power Users
On the main menu, you can use the arrow keys to maneuver around the menu items. Press Enter to se-
lect one. In most places in the program, you can also press Esc to back up (to a table from a form, to 
navigation from a table, or to Home from a navigation category).

On Mac, replace CTRL with Command.

From any screen:

CTRL+A to go to Chart of Accounts (Command+Shift+A on Mac)

CTRL+I to create a new Invoice

CTRL+J to go to Customers

CTRL+W to create a new Check/CC Charge

CTRL+Shift+I to go to Products

From the Navigation screens:

Arrow keys to move around, Enter to open

From a record screen:

Typing searches in most id fields; alternatively, CTRL+S (or F6) will do the same thing
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CTRL+N for new record (do this in an id field to make a new Customer for an Invoice, a new Item in the 
Item Code field on invoices or bills, etc.)

CTRL+P for print

CTRL+F for search

CTRL+D for delete main record; CTRL+R to delete in table

ALT+P for previous

ALT+N for next

CTRL+1 jumps to the first table entry (so, for example, it allows you to go straight to the items on an in-
voice). Note that if you’re in an entry field that has its own shortcuts (such as Customer ID) this will not  
work as that field will receive the entry.

In most split  forms, where there’s one table where you choose items to launch into another table,  
spacebar launches the item from the top form into the bottom form, for example on Reconciliations 
you can enter a whole group by hitting Space repeatedly. Also if you right click when importing, say, an 
Estimate, you can launch all items from one Estimate.

In most forms, you can use the Tab key to move between entry boxes, Shift+Tab to move back. When 
in a table, Tab and Shift+Tab will move only within the table; hold down CTRL while pressing the short-
cut to jump out of the table into the normal entry boxes.

In checkboxes, such as the Print checkbox on checks, you can press the spacebar when it has the key-
board focus to check or uncheck the box. This allows you to enter into that field without taking your 
hands off the keyboard.

Date Entry Shortcut
In any date field, you can enter a date in the current year in the format MMDD, e.g. 0102 for January 2. 
You can also press + and – to add or subtract a day from the date. You can also use + to add one day 
to the date and – to subtract one day. You can use [ and ] to increase and decrease by 1 week, or ; and 
' to increase and decrease by one month.

You can also go to the beginning of the current year, month, or week by pressing the first or last letter  
of the word, for example, Y takes you to the beginning of the year (or if you’re already there, to the be-
ginning of the previous year), and R takes you to the end of the year (or if you’re already there, to the 
end of the next year.

Add Customers, Vendors, and Items while Entering Data
In many fields throughout Fahrenheit, you can simply start typing to search for such things as a cus-
tomer, vendor, or item to add to an Invoice, Bill, Estimate, Sales or Purchase Order. You will automati-
cally be transferred to the search screen. You can also press CTRL+N to create a new record customer, 
vendor, or item, and automatically fill it in.
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In the search screen, Press Esc to restore the field to its prior state (cancel the search), Enter to use the 
first item on the list (or the selected item if you use the arrow keys to change the selection), or Tab to 
enter the text in the search box into the field (just as Tab would move to the next field, preserving the 
contents of the current field, if you were in a field that didn’t take you to the search screen).

You can also press CTRL+N in those fields to add a new record and automatically add it into the record 
you’re working on.

Math in Entry Fields
In money and quantity entry fields, you can use some math: + for addition, - for subtraction, * for multi-
plication, and / for division. Note that the result is calculated sequentially and does not follow mathe-
matical order of operations, so entering “2 + 2 * 2” (without the quotation marks) results in 8, not 6.

Tabular Navigation
When clicking a navigation button in the main menu, you’re brought to a tabular view by default. You 
can click on any of the records shown to bring them up in the form view, or click the New button in the 
corner to add a record. The button to the right of New, with the “you-are-here” symbol, is the Go to 
Record by ID button; if you click it you can go to, say, an Invoice by entering the Invoice number. Note 
that if you’re in a check or credit card register, the New button creates a new check or charge, so you 
will still have to navigate to the Bank Accounts menu to create receipts/deposits.

Adding a Logo to Reports and Editing Reports
Fahrenheit has the ability to edit reports (such as printed invoices), to do things such as adding your 
logo or moving various elements of the report around.

Go to File > Reports > Report Editor.

Then click the +:
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Choose Picture, then click the folder icon and browse to your picture. The width and height are inches. 
Give it a name, such as “Logo,” then click OK. Then use the Adjust Horizontal and Adjust Vertical but-
tons to set its placement (this is based on the bottom left corner because of the way PDF works).

If you put it where it obscures the address, you'll also need to adjust the address section. If you want to 
totally get rid of the address because it's in the logo, just give it an adjustment of 100 inches or some-
thing to send it into outer space.

You can also add a signature to checks by using a similar process in the Check Printing tab under File > 
Preferences.

If you move things around enough that there is now a large block of whitespace on top of or below the 
table in the report, you may want to use the Shrink Header Margin or Shrink Footer Margin to cut down 
on that whitespace.

To move any particular element of the report around, choose it in the drop-down (to the right of the +, 
it has “Inv Number” selected in the example above), then enter an adjustment in the Adjust Horizontal 
Placement or Adjust Vertical Placement boxes. Then press Tab to apply the change. Note that new ele-
ments appear at the bottom of the page, and the vertical adjustment moves items up, not down.
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Using Fahrenheit Search
Fahrenheit allows to to do advanced searches using nearly any form; this serves much the same pur-
pose as custom reports in some other software but allows you to interact with the data. From the Navi-
gation, you can click the Search button to go directly to search:

When viewing a record, you can click the Search button on the toolbar to switch to search:

Then you can enter the data to search for:
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Click the Run Search button (the arrow to the right of the Search button) to perform the search. If you  
press it without making any changes to the Search window, the search will bring up all records, just as if 
you clicked the button in the Navigation. Note that -1 means “do not search for this field” in a numeric 
field.

Sometimes you wish to do a search for a record and its children; for example, you may want to do a 
search for invoices that are to a particular customer and that also have a particular item on them. In 
this case you can use the Define Table Search Parameters red button to add, e.g., qualifications on 
which items must be on an invoice, to the main search.
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Universal Search
The Universal Search, which you can find in the Chart of Accounts section of the Navigation screens, is  
a bit different. It allows you to search through all transactions regardless of what kind of document is  
posting them, and should be useful for things like locating erroneous documents:

As you can see, you can search for a combination of factors. It should be noted that if looking for a 
stray value, it is useful to search for both the positive and negative versions of it. For example, if there is 
a $12.35 discrepancy in an account, and you are trying to find it, you should do a Universal Search with 
the Amount field set to 12.35 and also one with the Amount field set to -12.35.

Choosing a Default on Lists
For something like Terms or Tax Schedule, it’s unlikely that you’ll want to have to choose the correct  
value for every record; rather,  you would probably like a sensible default that can be changed as 
needed. For example, if you’re retailing hardware, you probably would like the Tax Schedule to auto-
matically be set to the default for your state, and in the few situations where it should actually be Tax 
Free, you can set that manually. Or when you enter a new customer, you would probably like their state 
to be automatically set to your home state by default. This is possible with Fahrenheit.

Go to the Menu (three lines in the upper left of the window) > File > Preferences > Lists. Choose the List 
you’d like to set a default for and click Choose Default:
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Then you can choose the form in which to set the default. Note that some things are auto-filled, and if  
you want your default to work, you need to set it at the highest level. For example, Terms and Tax 
Schedule on an Invoice are auto-filled when you set that Invoice’s customer, with the customer’s De-
fault Terms and Default Tax Schedule. So those defaults you should set on the Contacts form, not the 
Invoices form.

Then choose the field and the value, and then click the +. When you click the + button, the default 
should appear in the list box. You can then click Close to close the window.

Emailing from Fahrenheit
Any record that can be printed out of Fahrenheit can also be emailed as a PDF by clicking the Email 
button on the toolbar:

However, there is some setup involved, since Fahrenheit acts as an email client and uses your existing 
email address rather than sending all your messages through our servers (this has the advantages for 
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you of privacy and that we don’t need to charge you for the service). The first time you click the Email 
button, the Email Setup window will appear, and you can also edit it later by going to the Menu (three 
lines in the upper left of the window) > File > Preferences > Advanced and choosing Change Email Lo-
gin:

The setup requires some information on your email server. You may be able to get these out of your 
email program; for example, in Thunderbird, you can go to the Account Settings:
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Then click Outgoing Server to see the details on your server and copy them into Fahrenheit.

You can also get your email password in Thunderbird by searching the Settings (just above Account 
Settings in the screenshot above) for “password” and choosing Saved Passwords:

Then you can right click on the one that starts with “smtp,” click Copy Password, and paste that into the 
password field in Fahrenheit’s Email Setup window.

On documents like Invoices and Purchase Orders, the email address is automatically pulled in from the 
Customer or Vendor record, so make sure to set that when you enter the contact to make things maxi-
mally efficient.
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You will probably want a record of the emails that you send out of Fahrenheit. Fahrenheit offers the 
ability to send the email to yourself as well as the customer, which enables you to drag the message to 
your Sent folder and keep track of it as a sent message. To enable this, go to the Menu (three lines in  
the upper left of the window) > Reports > Report Editor, and check the When Emailing Documents, 
Send Copy to Self box:

By default, the emails sent out of Fahrenheit have a fairly bland message in the body of the email:

You can, however, tweak this message if you have additional details you’d like to send to the customer.  
To change the messages sent with Fahrenheit emails, go to the Menu (three lines in the upper left of the 
window) > File > Preferences > Report Emails:
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In the Table box, choose the screen from which you’re sending the email. In Email Body, enter the text 
of your new email message. You can use the placeholders ***tbl*** for the table name (which would ex-
pand to “Invoices” in the example above) and ***id*** for the record number. When your finished, press 
the + to add the custom email message so that it will be used.
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Banking in Fahrenheit
Most of the banking-related functions in Fahrenheit are accessed by clicking the Bank Accounts button 
in the Navigation screen or sidebar:

 

Entering a Bank Account
Now would be a good time to enter a bank account. You can create a bank account in Chart of Ac-
counts, but the program will fill in some details for you if you do it through Bank Accounts.

In the Bank Accounts menu you’ve just opened, click Bank Accounts, then New. Fahrenheit automati-
cally fills in Type and Parent, so you just have to fill an Account Number and Name. We suggest a 5-
digit account number beginning with 12 for the Account Number of a checking account.

Once you’re done there, we should add the opening balance to our account. After that we’ll be ready to 
really get to business and start entering checks.

Entering an Opening Balance
Manual ledger transactions are not very exciting, and in general you shouldn’t have to use them all that 
much. Generally you should only need to use them at your accountant’s direction, but the opening bal-
ance of an account is a special case. You should be able to carefully follow the directions given here 
without understanding credits and debits. If for some reason you do need to use a manual ledger 
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transaction, it’s recommended to verify the balance of the accounts after entering the transaction, to 
make sure everything is in fact correct.

To enter the opening balance, first click on the Miscellaneous button on Navigation screen or the left 
sidebar:

Then click the New Ledger Transaction button:
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When switching from a different software, or from paper records, it would be useful for reconciliation 
to start with the balance at the beginning of a bank statement, then enter all checks/charges/deposits 
that clear after that date.

Enter the balance using the screenshot below as a template; note that for the transaction to post, the 
“Difference” on the right above the transaction line items must be 0.00.

Because double-entry accounting requires that credits and debits balance, we offset the increase in the 
checking account (a debit) with an increase in equity (a credit). You don’t have to worry about the de-
tails of why it works, just be sure that you have both lines equal so that the transaction will post. To en-
ter the balance for a Credit Card account, you can use the same process, except enter the balance un-
der Credit and the equity under Credit.

Now in the menu bar, choose Reports > Balance Sheet. You should see that the balance of the checking 
account now equals the amount you entered as your adjustment under Manual Transactions.
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Now we can use the Bank Account we’ve created with the Expense Account that we created to write a 
check.

Writing a Check
Note that if the check is a payment of a Bill, it should be recorded through Bills > Bill Payments rather 
than this section in Bank Accounts.

Click the Bank Accounts button on the left sidebar, then the New button beside Write Checks/CC Pay-
ments:

This brings up the Write Checks Window. There are several interesting things to be noted here.

 

In the Payee box, start typing the name of the customer; Fahrenheit will automatically enter search 
mode. If you are writing a check to a contact that isn’t in the program, but you think you might write a  
check to the same contact again, you can press CTRL+N to add the contact to Fahrenheit and auto-
matically fill in the payee with that contact.
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The Print box is automatically checked; if you uncheck it (either by clicking it or by pressing the Space 
bar while it has the focus), Fahrenheit will (provided the Check # box still reads 0) automatically fill in  
the check number following the highest check number currently in the system. If you are going to print 
the check using Fahrenheit, leave the Check # box empty. If you’re entering a debit transaction or other 
non-numbered transaction, enter a 1 or something similar as you tab through, and unchecking Print will 
no longer enter the next check number. The Payee Name field is what will print on the printed check if 
you’re using the check printing functionality of Fahrenheit.

The Memo field is simply a convenience where you can make notes about the transaction.

To understand the Expense Account field, read the following chapter, “Understanding the Chart of Ac-
counts”. The Class and Job fields are also to be explained later. If different portions of a check should 
be assigned to several different Expense accounts, you can use the Split-outs box at the bottom of the 
form to assign them.

Note that unless you’re in the Contact or Expense Account boxes (where CTRL+N creates a new con-
tact or account and automatically fills it into the proper box), CTRL+N will create a new record, so if  
you’re entering a stack of checks or charges, pressing CTRL+N after completing the current record is a 
good way to create a new check without breaking flow by taking your hands off the keyboard.

Printing Checks
You can use Fahrenheit  to print the checks after you enter them into the system. Fahrenheit  uses 
Quickbooks-compatible checks, which can be purchased from many different vendors, and Fahrenheit 
also allows you to customize where the items on the checks print, to make it possible to use some other 
styles of printed checks. To choose the style of checks to print, go to File > Preferences > Check Printing:
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We recommend printing a page of checks on blank printer paper when starting out with Fahrenheit’s 
check printing, or after any modification in this tab, to avoid wasting check forms. If one of the items on 
the check is not where you want it, choose that section in the drop-down box (which has “Date” se-
lected in the screenshot above), and enter an amount in inches in the Adjust Horizontal Placement or 
Adjust Vertical Placement boxes. Note that this adjustment will not adjust all items on the check, just 
the one selected in the drop-down box, which gives you more flexibility if one item needs to go up, an-
other down, etc.

To print checks, go in the Main Menu to Bank Accounts > Print Checks. Use the new button to create a 
new print job. Choose the Account at the top of the window to bring up its checks.
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In the  Starting Number field, enter the number of the first check to be printed. Double-click on any 
available check in the top box to assign it to this print job; the checks for this job show up in the bottom 
box, where you can double-click them to remove them from the job.

Click the Print button to print the checks and have Fahrenheit assign them their proper check numbers:

Receiving Checks
Note that if the check is a payment of an Invoice, it should be recorded through Invoices > Payments 
Received rather than this section in Bank Accounts.

If you receive a check from someone, instead of using Write Checks, you should use Receive Checks, 
also in the Bank Accounts menu. It operates very similarly to the Write Checks window, but instead of  
recording the balance change immediately into the account register, it holds it in an intermediate cate-
gory of Undeposited Checks, which are then recorded into the register via a Deposit (see below). This 
allows you to track each monetary receipt individually, but still reconcile them as one lump sum, just as 
they show up on your bank statement.
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Deposits
When you deposit money into your checking or savings accounts, the deposit may include funds from 
many different sources, assigned to many different income accounts. However, you hand over these 
funds to the bank in one group, and they assign them to your account with them as one lump sum;  
they don’t care about where the money came from (as long as it was obtained legally, of course!). 
When reconciling your bank accounts, then, you’ll want to reconcile the lump sum, not every single indi-
vidual check you’ve received. That is the purpose of the deposit: to record exactly what is in that lump 
sum so that you can continue to track each receipt individually for your purposes.

To use the Deposits feature, then, you will of course have to have some incoming checks recorded, usu-
ally incoming checks or invoice payments.

Go to Bank Accounts > Deposits.

As usual, double-click a line in the Undeposited Receipts box to add it to this deposit. To remove an 
item from this deposit, right-click it and click Delete Item. If you’re trying to find an item in the Unde-
posited Receipts list, you can right click on the list and choose Set Sort Order to organize this list and 
make it easier to find the record you’re looking for.

Fahrenheit can print a Deposit Slip report that shows the contents of the deposit, if you would like a pa-
per copy for your records or to use when actually making the deposit at your banking institution. While 
in the Deposit, simply click the Print or PDF button to load the report:
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To set the bank account number to print on the Deposit Slip, go to the Chart of Accounts, open the ac-
count, and set the Institutional Account Number field.

Sometimes

Note that you can also send received payments directly to the bank account without needing to use a 
Deposit; this is useful when the sum is going directly to the bank and will not be lumped with other pay-
ments, such as a credit card payment. To make this happen, check the Autodepsit box on the Received 
Payment or Received Check window:

Sometimes when making a Deposit,  there are additional transfers from other accounts,  such as a 
transfer from Cash to Checking, or, conversely, you may want to withdraw cash when making a de-
posit. This money needs to be represented in the resulting balance of the account, so if you scroll down 
on the Deposit screen, you can find the Cash Back and Transfer From sections to accommodate these:
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Reconciliations
Cash on hand is a very important component of your assets. To know whether you can pay your bills, 
you need to know how much is actually in your bank accounts (perhaps even in your cash drawer if 
you don’t deposit it daily). To know the health of your business, you need to know the balance of one of 
your most important assets. Glancing at the current balance on the bank statement, or occasionally 
checking the balance online, is unlikely to give you a good picture of what is actually happening in the 
account, except in the most basic financial situations, since there are likely to be uncashed checks and 
deposits, and since unforeseen circumstances could easily change your financial status from day to 
day. In addition, those methods of financial management don’t deal with Accounts Receivable and 
Accounts Payable, critical components of your financial health, nor with some of the other things we’re 
looking at.

There is only one way to actually know the health of your business, and that is to keep good records.

And a critical component of a good record-keeping plan is reconciliation. You can even record every 
expense and every income, but your books can still  be off by a large amount. Why? Because you 
mistyped a number, or lost a receipt, or entered a transaction twice, or any of a long list of possible 
mistakes. I’ve done quite a bit of bookkeeping over the years, and I’ve become convinced that it’s com-
pletely impossible to enter transactions in a way that’s completely accurate. But, it is possible to have a 
set of books without mistakes, and the key is reconciliation. Reconciliation is a way of comparing your 
records to the bank’s, to double-check for errors, and to make sure they get fixed (I even found an er-
ror on the bank’s end once while reconciling; thankfully it was only for $0.02). Reconciliation, back in the 
days of pen and paper, used to be a difficult process, but with computers, it’s become quite a bit easier. 
And because of the importance of reconciliation, it’s been a special focus of Fahrenheit, and we’ve tried 
to make the process as easy as possible.

When you open up the Reconciliations window in Fahrenheit (found through the Banking link on the 
home screen), you see a list of Unreconciled Transactions. These are the transactions which your bank 
has not let you know are cleared yet; they’re still in your checking account:
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Can you see why we said that it’s a bad idea to trust the current online balance? We have several 
checks to vendors here, and it appears some of our vendors have been pretty slow about getting their 
money to the bank (which can actually be a sign of a business that’s doing well, since they can afford 
to sit on undeposited cash—if they were strapped for cash, they would be more likely to rush to the 
bank with the payment). If we simply used the ending balance of the bank statement, and considered 
that our current total, or if we used the online balance from the bank, we would think we still had sev-
eral thousand dollars that actually is likely to be taken out of our account at any time. Why doesn’t it 
show up on the bank’s balance? Because the bank doesn’t even know about it yet. But we can know 
about it, and we can use that information to get a better grip on our business’s health.

You should perform a reconciliation every time you receive a bank statement. You need the statement 
to perform the reconciliation, but delaying reconciliation too long can easily lead to abandoning it and 
losing track of your books again. Don’t allow yourself to create a pile of statements deeper than you 
have the discipline to go through and reconcile!

When you receive a bank statement, it probably looks something like this:
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1ST BANK OF CAMBRIDGE                                                         2023-12-15
Cambridge, MA

Opening balance: 9,349.00

Closing balance: 149,632.75

Transactions:

Date Payee Amount

2023-11-16 Loan Payment 150.00

2023-12-01 DEPOSIT 943.74

2023-11-15 Check #10000 350.00

2023-12-01 DEPOSIT 140,000.00

The first thing to verify is that the opening balance in the software for the reconciliation matches the 
opening balance of the statement; this is easy to check:

Here the opening balance does match; if it does not, which of course it won’t the first time you enter 
your records, that will need to be fixed before we can proceed. The fundamental thing to remember 
when you’re trying to get your opening balance correct is that the opening balance on the bank state-
ment is the total of all transactions that have cleared the bank; it’s the total of all the transactions that  
have ever appeared on a bank statement. If you have as series of bank statements that you’ve already 
entered into Fahrenheit, you can go backwards in time exploring the previously entered reconciliations 
until you find the earliest reconciliation where the Final Balance on Statement and Final Balance as 
Recorded do not match. You can then repair that reconciliation and (provided that’s the only mistake) 
the reconciliations following that one should then have correct opening balances which match those on 
the bank statements for those months.

When finding transactions in the Unreconciled Transactions box, if trying to find a particular transac-
tion, you can right-click on the list and choose Set Sort Order to arrange the list in such a way as to 
make it easier to find your transaction.
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The First Reconciliation
If this is your first reconciliation in the software, then things will be a bit more difficult, but still doable.  
You’ll enter an opening balance for the account itself into the software (this isn’t on the reconciliation,  
it’s elsewhere in the program since it applies directly to the bank account itself, and you’ll add it to the 
first reconciliation like a normal transaction—see the software manual for instructions how to do this),  
and you can start with the opening balance on the bank statement as that account opening balance.

This opening transaction will then show up in the Unreconciled Transactions on the reconciliation entry 
from, and if you add it to the reconciliation (by double-clicking on it), the ending balance on the recon-
ciliation in Fahrenheit will then match the opening balance on your bank statement. If you then move 
the transactions on the bank statement into the This Reconciliation box in Fahrenheit, your ending bal-
ance of the reconciliation will be the same on the bank statement and in the software (the opening bal-
ance on the reconciliation in Fahrenheit will be 0, since we’re reconciling the opening balance of the ac-
count as if it were a normal transaction). Which means that everything is correct. 

Of course, some of the transactions on this first statement may be transactions that happened before 
the month you’re reconciling (for example, if a vendor received a check from you three months ago but 
hasn’t cashed it yet). Since you may not have entered these transactions into Fahrenheit yet, you will 
have to go back and add them, then come back and put them on the reconciliation.

Reconciliation Difficulties
Of course, as we said before, humans aren’t perfect, and it’s not uncommon that when we finish recon-
ciling,  the  actual  ending  balance  of  the  bank  statement  won’t  line  up  with  the  Final  Balance  as 
Recorded in Fahrenheit. This means we’ve made a mistake. Either we’ve missed a transaction on the 
bank statement,  and not marked it  as reconciled in Fahrenheit,  or we’ve added a transaction that 
shouldn’t be added, or we entered a transaction with the wrong amount into Fahrenheit. We need to 
find this mistake and correct it.

First, make sure the opening balance is the same on the statement and in Fahrenheit. If it is, this is the 
Reconciliation with the error. If it’s not, use the Previous button to go back in time until you find a Rec-
onciliation where the Opening Balances match, but the Ending Balances do not; this is the Reconcilia-
tion with the error.

Usually  the best  step to take first  is  to go down through the transactions on the reconciliation in 
Fahrenheit. Find each transaction on the bank statement and check whether it’s on the Reconciliation in 
Fahrenheit, and that the amount is the same. If it’s not, then we’ve found an issue; go to the proper sec-
tion in Fahrenheit and add the transaction in. If it is, then draw a check mark beside it. Then do the  
same thing from the other end; going over the transactions on the Reconciliation in Fahrenheit and 
drawing a check mark on the other side when you find them on the bank statement. If you don’t find 
them on the bank statement, to remove that transaction from the reconciliation, right-click on it and 
click Remove from Reconciliation. Once you gone through this both ways, you should have located the 
error and been able to fix it.
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If your account has a service charge or if you’ve earned interest on the account, enter those numbers 
in the appropriate boxes as well. If you want to keep tabs on those amounts, you may wish to create, 
via Chart of Accounts, Income and Expense categories that you can use here.

As with most windows like this in Fahrenheit, if you find it easier, you can also select a line in the Unrec-
onciled box and hit spacebar on the keyboard to add it to the reconciliation, using the up and down ar-
rows to navigate among the transactions. That way you can reconcile without having to use the mouse 
as much, if you’re a power user who likes that sort of thing. You can also click on one record, then se-
lect multiple others by holding down CTRL while you click them. If you hold down Shift instead of CTRL, 
then the program will select the new record and all records in between the two selections.

Paying on Credit Cards and Loans
You could, of course, simply use Write Checks and set the Expense Account to the Credit Card or loan 
that you’re paying off. If, that is, you don’t have to pay any interest. But while Fahrenheit can’t save you 
from having to pay interest, it can at least make the process of recording those payments a little eas-
ier, since, by using the Pay on Accounts functionality, found under Bank Accounts > Pay on Accounts, 
you can record the payment on the principal and interest at the same time.

For details on the Check # and Print fields, see the Write Checks section. Choose the account you’re 
paying from, the account you’re paying off, then set the principal and interest amounts. If you’re track-
ing the amount you’re spending on interest with a special account, choose that in Interest Expense Ac-
count. Memo is a convenience field in which you can write any notes you wish to remember about the 
transaction.
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Loans
You pay on a loan in Fahrenheit in exactly the same way you pay on a credit card. To set up the loan, 
first you will need to create a Loan account. Go to Chart of Accounts and add a new Account with the  
Parent Account as 21200 Loans:

Set the Associated Institution to the financial institution giving you the loan. If you haven’t entered them 
yet, you can, as usual, press CTRL+N in that box to create them from right within Chart of Accounts.

Once that’s set up, go to Bank Accounts > Loans. Click New:
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In the Description box, type something that will uniquely describe this loan. In Financial Institution, enter 
the same organization you entered in Associated Institution under Chart of Accounts.

In Loan AP Account, enter the account you just created in Chart of Accounts.

In Deposit To, enter the bank account that you’re putting the money from the loan into.

And of course, Amount is the amount of the principal of the loan.

Now the loan is set up; you can view the remaining principal by going to Reports > Balance Sheet and 
finding the account you created here and entered in Loan AP Account.
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Transfers Between Accounts
Every so often, it becomes necessary to take money out of one checking or savings account and put it  
in a different one. You could do this procedure through a Manual Transaction, but if both of these ac-
counts are in Fahrenheit, it can be done more easily through a Transfer. Go to Bank Accounts > Trans-
fers Between Accounts:

In the Date, enter the date that the transfer is effective. In Transfer From and Transfer To, enter the ap-
propriate accounts.

In Amount, enter the amount of the Transfer.
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The Chart of Accounts

What the Accounts Mean
The Chart of Accounts is the heart of what goes on in Fahrenheit, or in any sophisticated modern ac-
counting system. Click the Chart button on the Navigation screen or the left sidebar:

You should see something like this:
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If you’ve never used a Chart of Accounts before, the concept may seem somewhat strange; the Chart 
encompasses both the things we normally think of as accounts, such as checking accounts and credit 
cards, and also more abstract concepts such as Accounts Payable and Expense categories. However, 
the Chart is at the center of modern double-entry accounting.

You don’t have to understand double-entry accounting to use Fahrenheit, since the program will mostly 
take care of the details for you (if you do want to learn it, a great place to start is Accounting Comes 
Alive by Mark Robilliard and Peter Frampton), but to get the most out of any modern double-entry ac-
counting system, you will have to dip your toe in by using the Chart of Accounts.

If this is your first time using double-entry software, you may have been using a spreadsheet to calcu-
late expenses and income, perhaps something like this:
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You can then create sums in the spreadsheet to calculate total expenses (the sum of all values in all Ex-
pense columns) and total income (the sum of the Job Income column). It also allows you to know, for 
example on the May 12 job in our example, how costs and income compare and whether a job is prof -
itable or not.

Accounts in the Chart of Accounts function the same way as the columns in the spreadsheet. There’s 
already  a  Revenue  (Income)  account,  #40000,  in  Fahrenheit.  There’s  also  an  Expenses  account, 
#50000. Each of these can be subdivided, in the same way as there are multiple Expense columns on 
the spreadsheet. Let’s create an account to match the Vehicle Expense account on the spreadsheet. Go 
to the Chart of Accounts and click New:

You’ll see a form like this; fill it out as shown:
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The most important thing, of course, besides the Account Number and Name, is the Account Type and 
Account Parent.  Setting Account Type to Expenses automatically sets Parent account to 50000 Ex-
penses, but you may need to change that when creating an account if you are subdividing the children 
of an Expense account.

Now when creating a check, such as the one described in the previous section, you can choose the 
50022 Metalwork Expense account that we just created in the Expense Account drop-down box:
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Once you’re familiar with the Chart of Accounts, you can add the new accounts that you need directly 
from choice boxes such as the Expense Account box throughout the program, by pressing CTRL+N in 
that field. But to start off, it may be helpful to do a few through the Chart of Accounts window to get a 
feel for what’s going on under the hood.

Now go to Reports > Income Statement.

 

Here you can see that the balance of the Vehicle Expense is $4000, which is the amount of the check 
we just wrote out. If we write another check using the same account, and reload the report, the amount  
will change. This way we can track the amounts that we spend on any particular category—the same 
thing we were doing with columns in the spreadsheet.
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Viewing Transaction History for an Account
Sometimes, such as when an account is showing a balance that you’re not expecting, you would like to  
inspect the history of the transactions that affect that account.  For Checking Accounts and Credit 
Cards, you can of course view the account register under Bank Accounts > Bank Accounts or Bank Ac-
counts > Credit Cards, but sometimes it’s useful for other accounts as well. To view the history, open the 
account under Chart of Accounts, then click the View Transactions button:

You can click any of the transactions in the window that pops up to open that transaction in the main 
Fahrenheit window for inspection. You can also set an end date and, optionally, a beginning date for 
the transactions, or export them to Excel for further analysis.

Closing the Books at End-of-Year
An important part of double-entry accounting is the closing of the books as part of your end-of-year 
procedure. This sets all Income/Revenue and Expense accounts to zero, so that when you pull up a fi-
nancial report,  the values you see for Income and Expense are the values for the current year. Of 
course, the income and expense that you’re zeroing out doesn’t just disappear; rather, it goes into the 
Retained Equity account (a descendant of Owner’s Equity), which gives you a record of how your year 
went. If you have a partnership, for example, you should create an Owner’s Equity subaccount for each 
partner, and then you can divide (with a Manual Transaction) the Retained Equity into the partners’ Eq-
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uity accounts by their ownership percentages, keeping track of how much of the business’s bank ac-
count nominally belongs to each partner even if the partners withdraw different amounts from the 
business.

To do a year-end closing of the books, go to Chart of Accounts on the Navigation screen, then choose 
Close Books/End of Year:

Choose the opening date as January 1st of the year, and the closing date as December 31st, unless you 
have a fiscal year that does not follow the calendar year, then click the Post box to actually do the ze-
roing out:
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Invoicing
To stay in business, you have to sell things, and to sell things, you have to have a way to charge your  
customers. Invoices are a way of letting the customers know how much they owe, as well as allowing 
you to keep track of revenue and how much you’re owed. They also give you a record of what you’ve 
sold and to whom it was sold.

Unless all your sales are tax-exempt, though, you’ll need to set up Tax Schedules before you start in-
voicing.

Tax Schedules
Tax Schedules is in the Invoices navigation section.

Code describes how the tax schedule choice will read on invoices and other documents. Description is a 
human-readable description for your own memory.

Enter the percentage of the tax charge as a decimal, e.g. 0.055 for 5.5%. Change the Account to Sales  
Tax Payable or a child of that account. The Governmental Entity tracks who you pay the tax to.

You can enter multiple lines to track multiple entities receiving parts of the tax bill.

Now the tax amounts will be automatically calculated on invoices which have this tax schedule set. You 
can use the 
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Invoices
In the Invoices navigation section, there is a normal Invoices section that you can click to view, edit, and 
create invoices. Above it, however, are two other special buttons that allow you to track particular kinds 
of invoices:

The Unpaid Invoices button tracks invoices which still have an outstanding balance. This allows you to 
see at a glance who still owes you money and to view any of these invoices.

The Unprinted Invoices button brings up invoices that don’t have the Printed box checked on the in-
voice screen. There is also an Unemailed Invoices button at the bottom of the section with Invoices that 
don’t have the emailed box checked. See Tracking Printed and Emailed Invoices for more info.

To enter a new invoice, click the + button next to the navigation link.
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The Date field of course is the effective date of the invoice. Checking the Printed box removes the in-
voice from the Unprinted Invoices list.

In the Customer ID and Job fields, you can start typing to bring up a search of your customers and 
jobs. Or you can press CTRL+N (Command+N on Mac) to create a new customer without leaving the 
invoice.

Choosing a customer will autofill the Mailing and Shipping Address fields, but you can edit them if you 
need to change the information for a single invoice and keep the old info as the actual contact info in 
the system.

The Note field is a description to be printed on the invoice.

The Secondary ID allows you to assign a second ID # to this invoice, if you have additional information 
to keep track of. For example, if you have a salesman in the field creating paper invoices, which are 
then entered into Fahrenheit, you can use this field for the ID # of the paper invoice, so that you can 
search for it later if a customer has questions on their invoice.

The AR account is the account that this invoice will post the customer’s debt to. Tax Schedule defines 
the schedule for all line items that don’t have their own schedule set. In Class, you can choose a class to 
post this invoice’s total to without affecting the accounts on the Chart of Accounts. The Secondary ID is 
useful in situations where you have an alternate method of creating invoices (for example, a salesman 
on the road who uses carbon copy invoices) and would like to track the ID used in the alternate 
method.

In the line items, you can start typing in the Item Code field to bring up a search of Products, or you 
can hit CTRL+N to create a new product without leaving the invoice. If you want to change the tax 
schedule for one item, or edit other item-specific properties, right click on the line item, and click “Edit 
Item” in the pop-up menu.

Click Return to go back to the invoice for this line item.

If you are going to change the tax schedule to one that is specific to this line item, first uncheck Change 
If Invoice Code is Changed. If you don’t do this, changing the invoice’s tax schedule will overwrite any 
changes you make here. You can change the Income Account to change the posting for the item, or 
Item Category to affect how discounts affect the item.

If you wish to apply a specific discount to this line item, enter it in the Line Item Discount field.

The fields below the total discounts are used to track if this line item was imported from a pre-sale doc-
ument and should not be manually edited.

When there are Billable Items, or items from pre-sale documents such as Sales Orders, which have not 
yet been invoiced, Fahrenheit will show a message that such items are available, and a button you can 
click to choose which ones to import into the invoice.

You can press the New Payment button to create a payment entry for this customer; it will take you to 
the Payments window and automatically fill in the customer so that you can choose their invoices.
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Discounts and Price Levels
While it might be nice to always receive the price one asked for their product, it doesn’t always work 
that way in the real world of business. You may offer discounts for repeat customers, for purchases at 
particular times of the year, or just to try to make the experience a happy one for the customer.

To add a discount, your items will need to have Item Categories assigned. We recommend leaving the 
Default category alone, and making all your own categories have Default as their parent (or a descen-
dant of Default as their parent). The Item Categories allow you to discount only particular groups of 
items, more or less automatically.

To enter the discounts, click Discounts and Price Levels on the Invoice screen, below the Invoice items 
table:

In the Invoice Items table, you can use the LI Discount field to discount only that particular item.

In the Price Levels table, you can use Price Levels to automatically insert the percentage and category, 
or set Item Category and Percentage manually to apply a custom discount.

Note that if you would like to have particular customers always receive specific discounts, you can set 
that up in the Contacts entry form.
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Terms
Most businesses who invoice customers also set terms on those invoices, which specify when the in-
voice must be paid. Sometimes they also offer a discount if the invoice is paid within a certain time. To 
create Terms in Fahrenheit, go to the Miscellaneous category, then select Payment Terms:

We recommend leaving the Default record in Terms as is, so that you have something to put in, say, 
vendor bills that don’t have explicit terms. To add your own Terms, create a new record. In the Name 
field, put a descriptive name; this is what will show up on the Invoices that you print for your customers.  
Then fill in the Days Until Due and Days With Discount fields.

The Discount, as the window says, should be entered as a decimal, so, for example, if you wanted to 
give a 2% discount if paid within 10 days, set the Days With Discount field to 10 and the Discount field to 
0.02.

The discount will be recorded as an expense on your financial records; in the Discount Expense Account 
you can choose this account. It would be a good idea to create an Expense account just for this and 
not use it for anything else, so that you can track your discounting exactly.

Invoice Payments
When you receive a customer payment on an Invoice (if the payment is not on an Invoice, use Receive 
Checks in the Banking section to process it), you can either go in the main navigation to Invoices > Pay-
ments Received, or you can use the New Payment button on the Invoice itself to receive the payment 
(and autofill the customer in). Either way, you’ll end up on this screen:
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You can start double-clicking on invoices in the Available Invoices section to apply the payment to 
them; the Amount field for the payment itself will automatically increase to match. Be sure to select the 
Deposit to Account field correctly; the payment will then be available to apply when you create a de-
posit for that account.

Note that once you’ve added an invoice to a payment, if you would like to jump back to that invoice, 
you can right-click on it in the Payment Applications table and click Go to Invoice and it will bring you 
back to that invoice. When you click the View Payments button from the invoice itself, you will see a 
similar table, this time of payments which are applied to that invoice; you can also right click on them 
and click Edit Item to be transferred directly to the payment.

Invoice Overpayments
Sometimes your customer may write out a check to you that is for more than the amount of the In-
voice. This can happen for several reasons; perhaps they’re planning to purchase more items but don’t 
know which items they are yet, so you can’t invoice them, or perhaps they changed their order and the 
new order is for less than the previous order, but they have already paid. In either case, you now have 
a liability to the customer for the amount of the overpayment, and may want to either apply that credit 
to a new invoice in the future, or repay the customer for the amount of the overpayment.

If we create a new Invoice (for example, when the customer decides what they actually want to order), 
then the overpayment will show up as an available credit on the Invoice screen, just as it would if we 
had issued a Credit Memo to the customer:
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We can click this button to be brought to the Apply Credits screen:

Double-click on the credit to apply it to this Invoice.
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If, on the other hand, the customer wants a refund of their overpayment, then we need to return to the  
Payments window and work in the Cash Back For Overpayment table:

In the Date, we enter the date on which we’re writing out the refund check to the customer. In From Ac-
count, we put the checking account from which the refund is being drawn. In Amount, of course, we put 
the amount of the refund. As with other places where we are writing checks, we leave the Check # at 0  
if we’re going to print. Otherwise, when we uncheck the Print box (either by clicking it or by pressing the 
Space bar when it has the focus), Fahrenheit will automatically fill in the Check # (of course we can 
change it if necessary).

Memorized, Duplicated, and Recurring Invoices
If you’re billing a customer on a regular basis, you can set an invoice to recur at a set interval, so that  
you don’t have to enter it every time. If it happens on a less regular schedule, you can memorize it and 
duplicate it as necessary.

With the invoice open, click the Actions button at the end of the toolbar:

Then choose Memorize, and the Memorize window will appear:

53 of 99



If you check the Memorize This Transaction box, then Fahrenheit will remember the invoice in the Mem-
orzed list. You can access this list by opening the Actions drop-down again, and clicking View Memo-
rized. Click on the Invoice to open it.

To duplicate an Invoice, whether memorized or otherwise, click the Actions drop-down and choose Du-
plicate. This will create a new Invoice that is a copy of the one you have open.

To make the Invoice recurring, check both the Memorize This Transaction box and the Recurring box. 
Change the drop-down (which has Monthly selected in the example above) to the desired recurrence.

If you have a number of recurring transactions, of course you’ll want to keep track of whether they’ve 
been given to the customer; see the next section for suggestions on how to do that.

Creating Batch Invoices
Sometimes we need to send an identical Invoice to multiple recipients. Fahrenheit allows you to do this 
with Batch Invoices. You’ll need to create one of the Invoices, and Memorize it (see the previous sec-
tion). Then click the Actions menu at the end of the toolbar:

Choose the Create Batch Records option, and the Create Batch Records window will appear:
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In the Choose a Memorized Invoice window, choose the Invoice you created for your template. Then, in 
the Customer box, you can type to search, just as in most of the other places where you choose a cus-
tomer in Fahrenheit. Once you’ve found the customer, select it and it will be added to the list of cus-
tomer to create the Invoice for. You can use the Save Current Customer List and Retrieve Saved List  
buttons if you will be using the same list of customers again.

When you’re done, press the Create and Close button if you’d like to just save the Invoices, and take 
care of distributing them later (in which case see Tracking Printed and Emailed Invoices for some de-
tails on keeping track of whether the Invoice has really been sent to the customer). Or press Create and 
Print if you’d like to immediately print the batch.

Tracking Printed and Emailed Invoices
Fahrenheit has the ability to remember whether Invoices have been printed or emailed, and allow you 
to load a list of ones that have not been printed, or ones that have not been emailed. The Invoice entry 
screen contains checkboxes for each of these:

You can manually check these after printing or emailing your Invoices; however, Fahrenheit can also fill 
them in for you when you perform those actions. To set this go to the Menu (three lines in the upper left 
of the window) > File > Preferences, choose the Functionality section, and check the Autofill Email and 
Print boxes:
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Then Fahrenheit will take care of checking them for you.

To see Invoices that have not been printed/emailed, use these navigation items in the Invoices section:
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Multi-line Descriptions on Invoices
By default, the Description field on Invoices is a single line. However, there are certain situations where 
you may want to have a multi-line description; for example, a cabinet shop may want to invoice a 
house with a single line, but then list all the rooms within the description. To make this possible, go to 
the Menu (three lines in the upper left of the window) > File > Preferences, choose the Functionality tab, 
and check Use Multi-line Table Cells:
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Barcode Scanning on Invoices
If you are selling items with barcodes, you may want to use a barcode scanner to enter the barcodes 
into the system (if you don’t have a scanner, you can purchase one from Fahrenheit Software that is 
compatible with Fahrenheit). This enables you to process orders more efficiently and effectively. Here 
we will only discuss the built-in barcoding capability of Fahrenheit; if you’re running a retail establish-
ment, the Yukon Point-of-Sale, which is deeply integrated with Fahrenheit, provides a more complete 
and efficient system for retail stores, including receipt printing, credit card processing, cash drawer in-
tegration, and retail automation. Contact your Fahrenheit representative for more details.

To be able to use barcode scanning in Fahrenheit, first you’ll need to enter your item’s barcode. Open 
the product in the Products screen and select the Barcode field:

Make sure your barcode scanner is attached and scan the item’s barcode to read it into the field in  
Fahrenheit.

In invoices, the built-in (not-Yukon) integration can be accessed by opening an Invoice and clicking the 
Barcode Scanner button:

The Barcode Scanner Entry window will appear:
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You can then begin scanning items to add them to the list. When you’re finished, press OK to add the 
items to the invoice.

Assessing Finance Charges
If you invoice customers, you may have a policy that interest is charged on Invoices that are overdue. 
Fahrenheit can automate this process, making it possible to charge on numerous invoices at the same 
time.

First, you will need to create a Finance Charge item in the Products section of Fahrenheit. Then you will 
need to tell Fahrenheit which item this is. Go to Miscellaneous > Company Information, and scroll to the 
bottom. Enter the Item Code for your new Finance Charge item into the Finance Charge Item Code box:
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Then you can assess the charges. In Navigation, go to the Invoices section, and click Assess Finance 
Charges at the bottom of the navigation section:

This will bring you to the Assess Finance Charges window:

In this window, you can see all overdue Invoices with their dates and their amounts. Enter the amount 
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of charges to be assessed on each one, then click OK, and Fahrenheit will automatically generate an 
Invoice for each customer for the amount to be charged.

If you’re auto-generating Invoices, such as happens here, you may want to keep track of which ones 
have been printed or emailed. See Tracking Printed and Emailed Invoices for more details on tracking 
this.

Importing Items onto an Invoice from Excel
You  can  import  items  onto  your  Invoice  from an  Excel  spreadsheet.  We recommend exporting  a 
spreadsheet from a completed Invoice first, to get a feeling for how the spreadsheet is to be laid out,  
and then using that sheet as a template for your new sheets.

61 of 99



Job Costing and Billable Items
For some businesses, such as grocery stores, the exact profitability of each transaction is either too 
small to calculate or is known in advance (when markup is set). For others, such as construction busi-
nesses, where jobs are quoted in advance, it’s very important to know exactly how accurate the esti-
mate was and how much profit or loss the job entailed. This requires, of course, a bit more recordkeep-
ing up front, but for many businesses it’s worth it.

In Fahrenheit, each job is connected to a specific customer, so the first thing to do is to make sure that 
customer has a record in Fahrenheit. Then click the Switch to Jobs View button:
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In Jobs View, click the New button above the Jobs table:

You will be brought to the Jobs form. The most important field here is of course the job’s name. Assign  
something informative that you’ll  be able to remember later;  e.g.  “Frank Burrows Kitchen Remodel 
Phase 1” or something like that.

Assigning Jobs on Bills
When you’re entering a bill into Fahrenheit, if all items on the bill are for the same job, you can set a de-
fault job for the bill, to be assigned to all line items on the bill:
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However, it’s more likely that you’ll have items for a number of different jobs on a single bill. In that  
case, leave Default job at 0, and right-click on any line item, whether Expenses or Items, to bring up the 
form to edit that line item. Find this section at the bottom of the form:
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First—and this is rather important—uncheck the Follows Default Job for Bill checkbox. Otherwise, if you 
edit the Default Job on the Bills screen, the value you’ve set here will be wiped out. Then you can start  
typing the name of the Job (which you assigned in the Jobs form) into the Job box to bring up the  
search screen.

If the item will be used up on the job, or in the production of the job, and won’t be in and of itself an 
item on the customer invoice, leave the Billable checkbox unchecked. If on the other hand you will be 
specifically billing the customer for the item and would like to keep track of the item while it’s hanging 
in limbo, paid for but not sold, then check the Billable box and set the Billable Customer field if it isn’t  
set already (meaning you’re using it for a customer without using the Jobs functionality, which is possi-
ble here).

If you’d like the billable items fields to show up directly on the Check and Bill screens, open File > Prefer-
ences > Advanced and check the Add Billable Options to Form Tables box.

Assigning Jobs on Invoices
If you own a business, hopefully you are able to sell items as well as buy them, and part of job costing 
is keeping track of job income, so that you can compare it to outgo—expenses—and find out whether 
you made your fortune or lost your shirt.
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Unlike Bills, invoices can only apply to one job at a time, and the Job field has pride of place right next  
to the Customer field on the Invoice:

As usual, this is a searchable field, and you can start typing in it to bring up the search screen for Jobs.

To import billable items onto invoices, click the Import Billable Items button on the Invoice form (which 
will only be visible if there are in fact available billable items):
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The top box on the screen that will appear will show available billable items for the customer chosen on 
the form, which as usual can be double-clicked to add them to the invoice.

The real benefit of using the billable items functionality in Fahrenheit is that if the markup you use on 
these items is consistent, you can make the markup automatic. On the Main Menu, go to Miscellaneous 
> Company Information. At the bottom of the form, fill out the Automatic Markup section:

Now when you import billable items, any items added to bills after you set this markup (or edited after  
setting the markup) should automatically appear with the proper selling price. Note: items that exist in 
Products automatically follow the selling price defined in Products; the automatic markup is only used 
if the item does not exist in Products..
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Tracking Job Income and Expenses
Once you have the sales and purchases for the job recorded, you can see the current status of income 
and expenses for the job. On the Main Menu, go to Customers > Jobs, and find the Job. Then click ei-
ther the Print button (to print the Job Costing Report) or the PDF button (to load the report onscreen 
as a PDF):
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Bills
Probably the vast majority of organizations use invoicing in some form or other. For some small orga-
nizations, recording bills may not be as useful; it depends on how fine-grained of record-keeping you 
want for your organization. If you’re not keeping track of inventory, and you will be using only one ex-
pense account for each check to a vendor, then you could use Checks and CC Charges to manage the 
outflow of cash from your organization. On the other hand, if you’re ordering disparate items from a 
vendor, which you would like to keep track of separately, or if you’re using inventory in any way, you 
should be using Bills to track those items.

The reason for this is that whereas Checks and CC Charges simply creates a lump sum to post to Ex-
penses, Bills enable a different expense account for each item, so that you can keep track of the out-
flow of cash by item or group of items instead of merely for checks. The larger your organization 
grows, the more likely that you will want or need to keep track of these things to have a handle on the 
state of your company.

At the top of the Bills section is an Unpaid Bills button. Click this to see any bills which you have not paid 
at a glance.

Creating and Editing Bills
To start with Bills, use the Bills section in the Bills category of navigation.
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In the Vendor field, enter the ID of the vendor you’re purchasing the items from. As usual, you can sim-
ply start typing to search in this field. In Bill Date, enter the proper date.

If Bill Received is checked, the bill as entered will post to the proper accounts. Careful: no posting will 
happen if this box is unchecked. The bill should be posted when received, but it’s likely that’s when you’ll  
be entering it anyway, so this box is checked by default. In Default Job, choose the job that the line  
items on the bill will be automatically assigned to if you don’t manually choose a job for them. If you’re 
not using jobs, or if each line item will be assigned to a different job, you can simply leave this at 0.

Under Items, enter the purchased items that are being billed. Note that Item Description will show the 
purchase description from Items, so if the Description shows up blank on Bills but not Invoices, it’s likely 
you didn’t enter a purchase description.

Using the Import from Purchase Order and Apply Vendor Credits buttons, you can pull elements from 
those documents, entered elsewhere, into Bills.

If you click the Expenses tab, you see a slightly different table:
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Here you can enter line items on the vendor’s bill document which do not correspond to items in your 
own inventory and for which you only want to record the price paid, not quantity purchased. In the 
Memo field, you can enter any extra information which you would like to keep track of.

Bill Payments
If you click the View Payments button in the Bills form, you will see a list of applied payments. You can 
right-click on any of these and click Edit Item in the pop-up menu that appears to view and edit those 
payments. You can also click the New Payment button to automatically fill in the Vendor on the Pay-
ment screen (since Bill Payments can apply to multiple bills simultaneously, you’ll still need to choose 
which Bills to apply the Payment to). Alternatively, you can access Bill Payments through the main nav-
igation, under Bills > Bill Payments.

Under Date, enter the date of the Payment itself, not the Bill.

In Vendor ID, as usual, you can start typing to search for the proper contact. Under Pay from Account, 
enter the checking or credit card account from which you’d like to pay the bill. Leave Print checked if 
you’re going to be printing a check to pay for this bill; otherwise uncheck the box.

On the right is the Available Bills table. Double-click on any entry in this table to apply the payment to  
it. It will then show up in the table of applied payments at the bottom of the screen.
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Vendor Credits
Under certain circumstances, such as defective merchandise, vendors from whom you purchase goods 
will offer you either credit on your account or a refund. Fahrenheit can help you handle these transac-
tions as well.

Under the main menu, go to Bills > Vendor Credits to create or access these records.

Under Date, enter the date when the credit was issued. Under Vendor, enter the vendor issuing the 
credit.

If the credit merely concerns an expensed item that’s not inventoried, you can use the Expenses tab,  
open above, to enter the Expense account you’d like reduced and the amount per account. If you’re re-
turning items that are inventoried in Fahrenheit, then you’ll need to use the Items tab to enter the items, 
so that they can be removed from the inventory calculation in the software.

The Credit is stored as a store credit to be applied against a bill from the vendor; if you receive it in  
cash, then click the Convert to Cash Refund button to manage it that way.

Updating Purchase Pricing on Items
When you enter a Bill into Fahrenheit, looking off the bill the vendor has sent you, you may find out 
that your vendor has changed the pricing on some of the items and you have to manually set the price 
for those items on the Bill. After you’ve done this, you will probably want the Purchase Price field on 
your Items to match the purchase prices that you’ve just entered, since these reflect the actual most re-
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cent purchase price. To do this, click the Actions menu at the end of the toolbar while viewing the Bill, 
and choose Update Product Costs to this Bill:

Memorized, Duplicated, and Recurring Bills
If a vendor is billing you on a regular basis, you can set a bill to recur at a set interval, so that you don’t 
have to enter it every time. If it happens on a less regular schedule, you can memorize it and duplicate 
it as necessary.

With the invoice open, click the Actions button at the end of the toolbar:

Then choose Memorize, and the Memorize window will appear:
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If you check the Memorize This Transaction box, then Fahrenheit will remember the Bill in the Memo-
rzed list. You can access this list by opening the Actions drop-down again, and clicking View Memorized. 
Click on the Invoice to open it.

To duplicate a Bill, whether memorized or otherwise, click the Actions drop-down and choose Duplicate. 
This will create a new Invoice that is a copy of the one you have open.

To make the Bill  recurring,  check both the Memorize This Transaction box and the Recurring box. 
Change the drop-down (which has Monthly selected in the example above) to the desired recurrence.
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Managing Contacts
Of course a business is nothing without people, and part of running a business is keeping track of the 
customers and vendors that are connected with your company.

Unlike some accounting software systems, Fahrenheit  treats customers and vendors identically,  as 
contacts. This means that if you have a customer who is also a vendor, you don’t have to enter that 
contact twice. Of course we can mark a particular contact as a customer or vendor so that we can re-
member which they are.

You can access the Customers and Vendors screens in Fahrenheit by clicking the Customers & Vendors 
link on the Home screen, or by using the link in the left sidebar:

You’ll then be brought to that navigation section:
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Jobs are described in the Job Costing and Billable Items section of this manual, so here we’ll focus on 
the Customers/Vendors section. As usual, we can click the Customer/Vendors button to get a list, or 
the + to create a new record:
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The Contact Code is primarily just for use in searches; it’s not actually printed on any customer-facing 
documents by default, so feel free to put in something that will help you to find the customer later, or  
just to let Fahrenheit fill it in as “UNTITLED” if you don’t want to bother with it at all.

Entering the Mailing/Billing Address fields automatically fills in the Shipping Address; of course you can 
edit the Shipping Address later if it’s different, but make sure to save the Shipping Address somewhere 
before editing the Mailing/Billing Address, if you want to keep it, since it will again be auto-filled if you 
edit the Mailing/Billing Address again.

The Email entered here is used when emailing Invoices etc. out of Fahrenheit so if you’re using that fea-
ture it’s a good idea to enter the email address here.

The Default AR Account, Default Tax Schedule, Default Sales Rep, and Default Terms are automatically 
filled in on Invoices when you set this customer as the customer for the Invoice. The Default Income Ac-
count is used for Receiving Checks; note that it is not used as the Income Account for Invoices made 
out to this customer as that income is sent to the Income Account of the Items on that Invoice.

In the Default Discounts table, you can add Price Levels that should be automatically applied to this 
customer’s Invoices. For more details, see Discounts and Price Levels.

At the top of this window, you see a series of button to switch to different views:
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What we see above is the Customer View, and that is what’s selected here. We can switch to Vendor 
View to enter information about the contact as a vendor:

As we see here, we can leave the First Name and Last Name fields empty if we do not have a contact 
to keep track of at the vendor. If we do have a specific rep, we can enter the rep’s name in those boxes.

Instead of Income and AR accounts, here we have AP and Expense accounts. The Default AP Account 
applies  to Bills  from this  vendor.  The Default  Expense Account applies  to Checks and Credit  Card 
Charges to this vendor. Note that the Default Expense Account is not used with Bills from this vendor, 
since those use the Expense Accounts of the Items on the Bill.

If the contact should receive a 1099, check the Receives 1099 box so that the contact will show up on 
the 1099 Vendor Summary report.
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Purchasing, Sales, and Quoting
Often it’s sufficient merely to enter an invoice or a bill to take care of customer or vendor interactions,  
but occasionally it’s useful to have a non-posting document tracking the transaction before it’s actually 
time to create the invoice or bill. The example of quoting is obvious. Purchase Orders are useful to send 
to your vendor as your order, and then you can import them into the bill automatically, saving time 
since you now only have to type the list of items once and can use it in the order and the bill.

Once you’ve created the Purchase Order, Sales Order, or Estimate, you can click the button on its  
screen, Convert to Bill (or Invoice) to directly create an invoice or bill with the working document’s items 
transferred to it.  Otherwise, especially if you have a situation such as more than one invoice which 
should receive items from a sales order, you can use the following method to transfer individual items 
off of the sales or purchase document into the actual posting document.

Once you’ve entered one of these documents, then create a new Invoice/Bill for the correct customer 
and a button will pop up to let you import it:

Click the button and you’ll see a form like this:
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From this form, you can see the open Estimate Line Items available for that customer. Double-click on 
any of them to close them and add them to the invoice. Or right-click on a line and choose Import All  
From This Estimate to speed the process up if the entire Estimate is to be imported.

Delete the appropriate line from the Invoice to re-open the Estimate line item.

When you’re done, click Return to Invoice to get back to the normal business of Invoice creation.

80 of 99



Products/Items
When invoicing or purchasing items, you can of course simply enter the item details, price, income or 
expense accounts, and other relevant details every time you sell the item. But if you’re selling the same 
item many times, this wastes a lot of time (and what businessperson has extra time to waste?). By en-
tering the item into Fahrenheit’s Products system once, you can simply enter the item code (or better 
yet, search for the item) into the invoice or bill and have the details filled in automatically.

To get started, go to the Products section and click New:
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You will be brought to the Items form:

The Item Code field is important because this is the ID that you will type in Invoices and other docu-
ments to bring up this item. Choose something memorable and distinctive (although if you insist on 
codes like 13904599003ES3WK43, Fahrenheit’s search functionality will hopefully save you from your-
self!). Item Description is what shows up as the description on Invoices, Sales Orders, and Estimates.  
Item Description for Purchase is for purchase documents such as Bills. Selling price and purchase price 
can be entered here or automatically inserted from sales or purchase documents via choices in the Ac-
tions menu at the top of the screen on those documents. See below for an explanation of the Auto-
matic Markup system.

As long as Follows Default Tax Schedule is checked, it doesn’t matter what’s in the Tax Schedule box,  
since the correct Tax Schedule will be inserted from the Invoice when the item is added. Uncheck this 
box and select a Tax Schedule for such items as food, where tax will never be charged.

Income Account, Expense Account, Asset Account (for inventoried items), and COGS Account (Cost of 
Goods Sold, for inventoried items) are the accounts adjusted when this item is sold or bought. This can 
be changed from the Invoice or Bill, so you’re not stuck with this value forever, but choosing a sane de-
fault can save time down the road.

Item Category is used for discounting, described elsewhere.
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Inventoried Items
If you want Fahrenheit to manage inventory quantities and Cost of Goods Sold for an item, make sure 
that the Inventoried Item box is checked on the Items page. After that, Fahrenheit will automatically 
add to the value of inventory when that item is purchased, and transfer value from inventory to Cost of 
Goods Sold when the item is invoiced. You can use the Inventory Summary report to view current stock.

Of course, when you set up Fahrenheit, you’re likely to have some items already in stock; at the end of  
the year, when you count your actual stock, you’ll also likely find that it doesn’t quite match what the 
Inventory Summary thinks it is. To adjust Fahrenheit to match what’s really in stock, click on the Prod-
ucts category, then create a new Inventory Adjustment.

The Date, of course, is the date when the inventory adjustment is effective. This is important because 
Fahrenheit uses FIFO (First-in, First-out) inventory accounting, not average costing like Quickbooks, so 
the items with the earliest effective date will be the first ones removed from inventory (with their pur-
chase value removed from Inventory and added to Cost of Goods Sold) when this particular item is in-
voiced. If you are entering adjustments for more than one item and would like them to have different  
effective dates, create separate Inventory Adjustment records. The Memo is simply a human-readable 
description for the list of adjustments, so that when you go to find a particular adjustment, it’s a little bit 
easier.

For the line items, Item Code is the code defined in Products. Note that if the Item Code is not filled out,  
or doesn’t match Products, the adjustment will not post correctly. The Purchase Value field is only used 

83 of 99



for increases in Inventory and is used for value in Inventory and also the Cost of Goods Sold when 
these items are invoiced.

Setting Up Automatic Price Updates
On the Items form, there is a section for Automatic markup:

If you would like to automatically mark up the item’s price based on its cost to you, check the Auto-
matic Markup box. The multiplier is a number that the purchase price is multiplied by to get the selling 
price, so for 40%, enter 1.4 in this box. You can also use the Divisor box in a similar way, depending on 
whether you’re pricing by margin or markup. The result of that multiplication and/or division is then 
added to the Addend to come up with the final selling price. Note that if you’re not using one of either 
the Multiplier or the Divider, you should set it to 1 to keep it from having any effect on the calculation.

Note that to avoid unexpected price swings, the item is not automatically updated when you enter it on 
a bill. After entering the Bill, click the Actions button in the upper right of the form:

 

Click Update Product Costs to This Bill. The Purchase Price field on all items on the bill will then be up -
dated and the selling price of items with Automatic Markup enabled will be updated. If you re-open the 
item, you see that its selling price has been changed:
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You can also set selling price on items off of an invoice, to update the price for future invoices to match 
the updated price you just entered on this invoice. Click the Actions button from in the invoice, then click 
Update Product Pricing to This Invoice.

You can also use the Update to Current Pricing/Costs button (also under Actions) within a bill or invoice 
to update the invoice or bill to the current pricing in Products. This also works for estimates, so that you 
can update an estimate to current pricing easily.

Assemblies
Sometimes you want to sell an item that is composed of, or contains, other items. For example, you 
may be using Fahrenheit to manage inventory of some raw material such as 2x4s. When you sell an 
item made with these items (a building, for example), you want these to be properly subtracted from 
inventory, but you don’t want the customer to see them on the invoice. Conversely, you may have 
items that are upsells to another item, for example premium windows for that building, and want them 
to show up on the invoice so that the customer can see exactly which items are making the price what 
it is.

The Items form contains a table in which you can add in these items:

Simply enter the quantity of items you’re adding, and the Item Code (if you start typing, it will automat-
ically open search). Note that the price of the subitems is automatically added to the price of the par-
ent item when they’re entered into an invoice or bill, so take that into consideration when setting the 
price of the parent item.
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When you enter  these items into  Invoices  or  Bills,  Fahrenheit  will  automatically  create  child  items 
matching the ones you entered on the Items page. To verify this, right-click on the line item in Invoices 
or Bills and click Edit Item. You’ll see the subitems in the table under that item. You can also manually 
add subitems in situations where you are selling or purchasing an assembly too rarely for it to be worth 
having in your Items, or where the subitems are different each time (e.g.  in the upselling situation 
above).

In File > Preferences > Advanced is a setting to choose whether subitems show up individually on in-
voices and bills, or whether they’re grouped with their parent item:

Note that when you’re entering the Line Items into an invoice or bill, the Price field will show the markup 
for the assembly, while Line Total will show the total including the price of the subitems.

This is currently not working with Estimates, Sales Orders, or Purchase Orders, but that functionality is 
in the works.

Item Categories
Item Categories can also be accessed from the Products menu. We recommend keeping the Default 
category and using it as the parent of all other categories, to make it possible to apply certain dis-
counts across the board.

Price Levels
Price Levels define a percentage discount that applies only to items of a particular Item Category.
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Importing Contacts and Items
If you’ve already spent some time entering data into another program, you’ve probably spent a lot of 
time entering customers, vendors, and products, and probably you don’t want to spend all that time 
entering all those details again. Thankfully most systems have a way to export that data to an Excel file 
,which Fahrenheit can then import.

First, export your data to Excel from the other program, then in Fahrenheit open the appropriate form 
(we’ll use Items here for our example) and click the XLS button:

The Import/Export Excel window will appear:

Even if you’re planning to import an existing file, it’s recommended to start by exporting a file from 
Fahrenheit using this window, since the file to be imported must have the correct headers in Excel to 
import correctly, and the easiest way to accomplish this is to start with a Fahrenheit-exported file and 
paste the columns from your other file into that file:
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If you need help determining how to properly format the values, simply create a couple sample records 
in Fahrenheit first to see how the file exports those values.

When saving your updated file, note that if Excel saves the file in the OOXML, or XLSX, format, it may 
not import properly in Fahrenheit. Make sure to save as an Excel 97-2003 (.xls) file:

After entering your data, return to Fahrenheit and click the XLS button again, this time going to the Im-
port tab:

Use the Browse button to find your file, then click the Import button immediately underneath it to add 
the records.

Later, if you want to do a bulk update of your item records, you can export your file, make the proper 
changes, and change the Import window from Skip Existing to Update Existing.

There are two primary reasons an Excel import job may fail, both of which have to do with the fact that 
Fahrenheit uses the Item Code or Customer Code to differentiate records when doing an Excel import. 
If there are duplicate IDs, it should give you the troublesome IDs so that you can change one or the 
other.
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The other reason it may fail is if the Code field on the spreadsheet to be imported is empty, since then  
Fahrenheit doesn’t know how to check whether the record is already in the database. In this case, since 
the codes are not necessary for normal use, the recommended way of dealing with it is to enter a 1 in 
the first record. Then select the cell and a small box will appear in the lower right corner:

You can click on this and, holding the mouse button down, drag it down over the rest of the records. Ex-
cel will then fill the Code on these records with 2, 3, etc. Then Fahrenheit will know how to identify the 
records and you should be able to complete the import.
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Fahrenheit Server
Unlike many accounting software packages these days, it’s easy to use Fahrenheit in a single-user con-
figuration on your own desktop; there’s no database to manage, no server to install and run, basically 
no management except backups. But if your business is successful,  there may come a point when 
that’s not enough; you need multiple people to be able to access Fahrenheit at the same time from 
their own desks. This is also possible with Fahrenheit, with the Fahrenheit Server add-on.

You may be surprised to learn, though, that with Fahrenheit Server, there’s still no database to manage, 
no detailed web server configuration—after you’ve set up an SSL certificate (and this chapter contains 
detailed step-by-step instructions on how to do that) and created users, there’s still very little manage-
ment except backups! We think the vast majority of the recent trend toward cloud software has been 
fueled by the difficulty of managing some on-premise software, and with Fahrenheit we’re determined 
to prove that you don’t have to give up control of your data and your systems to have ease of use and  
ease of deployment.

If you’re sending your data across the network, though, you don’t want snoopers reading everything 
that goes across the wire (passwords, data, reports…). While you can run Fahrenheit Server without en-
cryption, unless you’re in a very secure environment, we recommend enabling encryption of the data 
prior to transfer. If you already have an SSL Certificate for the machine you’ll be running Fahrenheit 
Server on, you can use that; otherwise, you’ll can use Keystore Explorer to generate one (check our file-
server for the Windows installer; for Linux and Mac, or to make sure you have an up-to-date Windows 
installer, visit www.keystore-explorer.org to download the program).

Creating an SSL Certificate with KeyStore Explorer
If you already have your certificate, you can skip this section.

Open KeyStore Explorer and click “Create a New KeyStore”:

Choose JKS as the keystore type:
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When the new keystore opens, click Tools > Generate Key Pair:

The next screen’s defaults of RSA 2048 should be all right:
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The next screen should be mostly all right, so click the Edit Name button:

Fill the Edit Name window in with your company information and click OK:
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Then click OK on the Generate Key Pair Certificate window, enter a memorable name for the alias 
when it asks for that, and choose a password for your certificate. Since Fahrenheit needs to store the 
password in plain text to be able to open the keystore, the password should not be considered much 
protection for the keystore; it is your responsibility to ensure that unauthorized personnel never have 
access to the keystore file.

Now your new certificate is created:

Now you need to save it. Click File > Save, enter your keystore password when prompted, and when it  
opens the save dialog, enter a name such as “keys.jks”. Be sure to enter the “.jks” on the end as the pro-
gram will unfortunately not enter it for you.

Now you can close KeyStore Explorer and return to Fahrenheit on the server computer.

NOTE: a malicious intruder who is able to access the keystore file will gain the ability to unencrypt 
your network traffic, and also to spoof your server with a man-in-the-middle attack. Be VERY 
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CAREFUL to protect the certificate. It is also recommended to change the certificate occasionally 
so that if it is stolen, the damage is limited.

Managing Remote Users
Before you can actually log in to the server from a different computer, you’ll need to create some user 
accounts. While in the file you’re going to be using over the server (but not connected through the 
server), go to Server > Manage Server Users.

You can click on any user in the list to edit their account, or click the + in the upper right to create a new 
user:

Username is the name that the user will actually use to log in, such as jsmith. Display Name is the user’s 
actual name formatted for human consumption, such as John Smith. If Has Administrator Privileges is 
check, then the user receives access to all functionality regardless of whether any other boxes are 
checked.

If the user is not an administrator, then you can choose whether to give the user read and write privi-
leges for particular parts of the software. You can use the Check All and Uncheck All buttons to make 
things a bit faster. Note that allowing some tables will automatically give access to any tables that 
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need to be viewed in the forms for the original table; for example, enabling Customers will automati-
cally give access to Invoices, since there is an Invoices table on the Customers form. Click OK to save 
the user and return to the main Users screen.

Starting the Server
Since the database can only be accessed by one process at a time, switch Fahrenheit to another file,  
then close it and open it again to clear the locks. If possible, also verify that any active firewall is not 
blocking the ports to be used.

Then click on the Server menu at the top of the screen, and choose Manage Server. You should see the 
following screen:

If you have an existing server configuration, the software will automatically load it into this screen. If 
you would like to import the existing configuration from your desktop installation, you can click Import 
From Desktop.

Choose the set of books you’d like to access through the server in the Database To Launch box. You 
can click the folder icon to the right of the box to use a file picker window to choose the books.
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If you experience difficulties accessing your server, you may need to run over a different port; if so, 
check the Custom Server Port box and adjust the value appropriately. If you’re in a setting where secu-
rity requirements do not prevent it, you can also use the Custom Login Timeout to extend the amount 
of time a user continues to be able to access the system after logging in.

In Location of .JKS Keystore you can choose the keystore you created in Keystore Explorer; you can 
click the folder icon to the right of the text box to use a file picker window to select the keystore. Enter  
the keystore’s password in the Keystore Password box.

Click Set License Key to set the license key, unless you’re using a trial version. This will need to be a li-
cense with Server functionality activated.

If you fill in the Config Backup box, the configuration will be saved to a separate location as well as be-
ing deployed.

Now you can click the red Deploy Configuration button to copy the server configuration to the proper 
location. If you have not done so, click the Install button to enable the server service on Windows. Then 
click Start to run the server. After a moment, click the Check Status button to make sure the service is 
active and running. If it is not, click View Run Logs to view the error log to see what is going wrong.

Now the service should automatically start when you turn on your computer. You can stop it at any 
time by re-opening the Server Manager and clicking Stop. You can also click Uninstall to prevent it from 
starting the next time the computer is turned on.

Logging in to the Server
If you don’t have a dedicated server setup (if, for example, you’re an accounting office where you may 
start up the server occasionally for only a few minutes on a regular workstation so that a colleague 
can make a few changes), you may not have a hostname set up for your computer. You can then use 
the IP address of your computer when logging in. To find out what this is, on Windows open up the Ter-
minal (on Windows 11) or Command Prompt (on older versions) and type:

ipconfig
This should bring up something like this:
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What you want here is the IPv4 address; see arrow in illustration. Write this down so that you have it 
when you go to access the server.

After clicking Start Server, open Fahrenheit on another computer connected to the network.

If the Switch Books screen opens, click the Connect to Server Instead button. Otherwise go to the Menu 
(three lines in the upper left of the window) >  File > Connect to Server to login:
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The username and password are the ones you entered in Manage Server Users. In the Server box, en-
ter the ip address you found preceded by  https://. For example, to connect to the example shown 
above, you would enter the following:

https://192.168.1.68

Then you can click OK and you should be logged into the server and able to do most things as if you 
were operating on a local file.

Running Server Headless on Linux
Fahrenheit Server can also run on Linux, even without a monitor attached. You must have Fahrenheit it-
self installed normally, then you can install the server. So starting with a fresh copy of Fahrenheit, newly 
unzipped into a folder:

chmod +x install.sh
chmod +x installServer.sh
sudo ./install.sh
sudo ./installServer.sh

This will install, enable, and start (if serverConfig.json is present in /opt/Fahrenheit; you can create it 
with the Server Manager on another computer) the service. You can then control it like normal with 
systemctl:

sudo systemctl stop fahrenheit.service
sudo systemctl start fahrenheit.service

A few notes specifically for Linux:

The installer creates the fahrenheit user and group; the books folder and everything in it used must 
have read and write permissions by that user or Server will not function properly. For example:

sudo chown -R fahrenheit /home/fahrenheit/finances/

The serverConfig.json file must be present in /opt/Fahrenheit for the server to read its configuration. If  
you are running headless and cannot export the file directly on the server machine, you can use an ex-
port from another computer, and edit the JSON file manually to make sure the following keys are set:

certificateSet: true
certificateLocation: <location of your JKS keystore>
keystorePassSet: true
keystorePass: <password of your JKS keystore>
defaultDB: <the location of your books database>

The server then should be accessible as normal. On Linux, run the ip address command to find the 
address of the server.

The installer will delete and re-create the /opt/Fahrenheit folder; back up your serverConfig.json be-
fore upgrading Fahrenheit!
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API Server
If you have another program doing specialized tasks, you may want to integrate Fahrenheit with that 
program using your own code. Fahrenheit contains a JSON API, which operates on HTTP (for local con-
nections) or HTTPS (where you connect to the same Fahrenheit Server that the Fahrenheit application 
is connecting to).

To access the local server,  go to Server > Start API Server.  Then visit  http://localhost:8088 in your 
browser for instructions on how to manipulate the server.

To access the Fahrenheit Server remotely over HTTPS, go to Server > Manage API Keys to create an 
API Key to log in with. The instructions under the local API Server explain how to use this API Key to log 
in.
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